1.2. Rails 2.x or 3.x?

Rails 2.3.x is no longer up to date! Don't do this do yourself. If you are looking for a book on Rails 2.3.x, then you need to make a quick trip to Amazon. This book will only help you with 3.2.x.

Important

A programming language like Ruby and a framework like Rails are constantly changing and evolving. Please visit http://xyzpub.com/en/ruby-on-rails/3.2/ from time to time. On this web page, I will publish current information and chapter updates if applicable.

Updates about this book will be published on my Twitter feed.